How to Block Google DNS on Roku Using Mikrotik Router

Note: This guide is supplied by a friendly Unlocator user. We don't provide support for this setup. The guide is provided as is.

This guide applies to ALL mikrotik routers running Router OS.

For Windows users

  1. Login to Mikrotik router using Winbox tool
  2. Click "New Terminal" button from the left side menu
  3. When a terminal window opens, copy below content, right click inside the terminal and paste. (Make sure to hit Enter key inside the terminal window once before closing window)
    /ip firewall address-list
    add address=8.8.8.8 list=GOOGLE_DNS
    add address=8.8.4.4 list=GOOGLE_DNS
    /ip firewall filter
    add action=drop chain=forward dst-address-list=GOOGLE_DNS place-before=0

For Mac users

Winbox tool is not available for Mac users. Mac users could either login to router via web or SSH into the device and perform step 3 above.

Still need help? Contact Us Contact Us